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Intersection Design - 3D Model Detailing
This course is for the 2021 Release 1 version of:

OpenRoads Designer CONNECT Edition
OpenRail Designer CONNECT Edition

About this Practice Workbook...
 This workbook is designed for use in Live instructor-led training and for OnDemand self study. OnDemand videos 

for this course are available on the LEARNserver and through CONNECT Advisor.

 This PDF file includes bookmarks providing an overview of the document. Click on a bookmark to quickly jump to 
any section in the file.

 Both Imperial and Metric files are included in the dataset. Throughout this practice workbook Imperial values are 
specified first and the metric values second with the metric values enclosed in square brackets. 
For example: 12.0’ [3.4m].

 This course workbook uses the Training and Examples WorkSpace and the Training-Imperial or
Training-Metric WorkSet delivered with the software.

 The terms “Left-click”, “Click”, “Select” and “Data” are used interchangeably to represent pressing the left mouse 
button. The terms “Right-click” and “Reset” are also used interchangeably to represent pressing the right mouse 
button. If your mouse buttons are assigned differently, such as for left-handed use, you will need to adjust 
accordingly.

Have a Question? Need Help?
If you have questions while taking this course, search in CONNECT Advisor for related courses and topics. You can also 
submit questions to the Civil Design Forum on Bentley Communities where peers and Bentley subject matter experts are 
available to help.

Course Level: Intermediate

http://learn.bentley.com
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Course Overview

This course teaches tools and techniques that can be used to accurately model a complex intersection in 3D.

In this course, you will learn how to:

 Use Linear Templates to create the curb, sidewalk and side slope grading along the edges of pavement and islands.

 Use Surface Templates to apply material thickness to the pavement surface and median islands.

 Create a Finished Grade Terrain Model using Graphical Filters.

 Export Finished Grade Terrain Model to LandXML format.
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Intersection Layout

The intersection layout is shown below in 2D and 3D. The finished grade terrain model that represents the pavement surface and all of the 2D 
and 3D geometry has already been defined. To learn how this was accomplished see the course titled: Intersection Design-Horizontal and 
Vertical Geometry.

The objective of this course is to accurately model this intersection in a 3D model and produce a finished grade terrain model for all roadways.
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Exercise 1: Model the Islands and Median

Description 
In this exercise, you will model the islands and the raised median.

Skills Taught
 Create a 3D Model of an Island using Linear Templates and Surface Templates

 Create a 3D Model of the Raised Median using Linear Templates and Surface Templates
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Open Intersection Layout Design File

In this section you will open the intersection design file. All the necessary references have already been attached.

1. Start the software.

2. Set the WorkSpace and WorkSet.

The WorkSpace and WorkSet define standards that are used by the software, and the ones used for this training are installed during the 
software installation. 

Typically, the WorkSpace contains organizational standards and the WorkSet contains project standards.

a. Select Training and Examples from the WorkSpace drop-down menu.

b. Select Training-Imperial [Training-Metric] from the WorkSet drop-down 
menu.

3. Open the intersection layout file.

a. Browse to the folder where you unzipped the dataset files and select the design file Intersection-Model.dgn.
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4. Review the attached reference files.

a. Select Home > Primary > Attach Tools > References

b. Note that we have several files attached. We will be using these files as we progress through the course

c. Close the References dialog.

5. Review the 2D and 3D views. 

 2D and 3D horizontal edge of pavement geometric elements have already been defined.

 A proposed terrain model representing the top finished grade pavement surface has already been created.



Copyright © 2021 Bentley Systems, Incorporated 7DO NOT DISTRIBUTE - Printing for student use is permitted

Apply Linear Templates to Model the Curb within the Islands and Median

In this exercise, you will model the island and median curbs using Linear Templates. The Apply Linear Template tool allows you to create 3D 
components within the model by selecting a template from the active template library and applying it along a 3D linear element. 

This tool is very useful in modeling design elements such as curbs, medians, ditches, walls, levees, and channels. In order to apply the 
linear template the civil geometry must have a profile associated with it. 

1. Open the Template Library and Review the Linear Templates

a. Select Corridors > Create > Template > Create Template, the Create Template window will appear and load the default template 
library.

b. Select File > Open and Select the Intersection Detailing.itl file.

c. Expand the Linear Templates folder.

d. Double Left Click on Curb Type 1 - Aggbase to set it as the active template.

e. Review the template and note this template is composed of a concrete curb and aggregate 
base. You are going to apply this template to the islands and the median.

f. Close the Create Template window.
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2. Apply the Linear Template to Create the Curb Along the Median

a. Select Model Detailing > 3D Tools > Apply Linear Template

b. In View 1, Following the heads up prompts (after each prompt, Left-click to accept values and move to next prompt):

 Feature Definition: Linear Template > Final

 Name: Median Curb

 Locate Element to Apply Template: Select the median edge of pavement geometry.

 Template: Press <ALT> and the Down Arrow to open the template library. The Pick Template window will appear.

 Browse to the Linear Templates folder and select Curb Type 1 - Aggbase and click OK

 Start Station: Press <ALT> to lock to start

 End Station: Press <ALT> to lock to end

Select Side - Reflect Option: Move the cursor to the inside of the median.

Tip: If the curb displays on the wrong side, the Properties dialog can be used to flip the Reflect option.

 Exterior Corner Sweep Angle: Do not change the setting. 

 Description: Median Curb

c. The linear template is placed and the components displayed in the 3D model (View 2). 
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3. Apply the Curb Type 1 - Aggbase Linear Template to the north island.

a. Select the Apply Linear Template tool.

b. On the dialog box, toggle off all the check boxes to UNLOCK all the tool settings.

c. In View 1, Following the heads up prompts (after each prompt, Left-click to accept values and move to next prompt):

 Locate Element to Apply Template: Select the north 
island edge of pavement element.

 Feature Definition: Linear Template > Final

 Name: North Island Curb

 Template: Press <ALT> and the Down Arrow to open the 
template library. The Pick Template window will appear.

 Browse to the Linear Templates folder and select Curb 
Type 1 - Aggbase and click OK

 Start Station: Press <ALT> to lock to start

 End Station: Press <ALT> to lock to end

 Select Side - Reflect Option: Move the cursor to the 
inside of the north island.

 Exterior Corner Sweep Angle: Do not change the setting. 

 Description: North Island Curb

The North Island Linear Template is now placed and the components are displayed in the 3D model (View 2).
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4. Apply the Curb Type 1 - Aggbase Linear Template to the south island.

a. Select the Apply Linear Template tool.

b. On the dialog box, toggle off all the check boxes to UNLOCK all the tool settings.

c. In View 1, Following the heads up prompts (after each prompt, Left-click to accept values and move to next prompt):

 Locate Element to Apply Template: Select the south island edge of pavement element.

 Feature Definition: Linear Template > Final

 Name: South Island Curb

 Template: Press <ALT> and the Down Arrow to open the template library. The Pick Template window will appear.

 Browse to the Linear Templates folder and select Curb Type 1 - Aggbase and click OK

 Start Station: Press <ALT> to lock to start

 End Station: Press <ALT> to lock to end

 Select Side - Reflect Option: Move the cursor to the inside of the south island.

 Exterior Corner Sweep Angle: Do not change the setting. 

 Description: South Island Curb

The South Island Linear Template is now placed and the components are displayed in the 3D model (View 2).
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TIP: Sometimes it’s necessary to adjust the stroking definition values to increase or decrease the accuracy of the linear templates when 
placed along linear elements, curves and profiles. 

To review or modify the stroking definition values, select the geometric element that the linear template is attached to in 2D or 3D. Then 
select Home > Primary > Properties to access the full properties of the element. This will give you access to all of the element properties 
as well as the Stroking Definition where adjustments can be made. 

The default Stroking Definition values are defined with the following configuration variables in the workspace.
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Exercise 2: Model the Interior Areas of the Islands and Median

Description
In this exercise, you will model the area inside of the islands and the median by creating a terrain for each and then applying a surface 
template that will create the concrete caps.

Skills Taught
 Use the terrain tools to create the interior of the islands and the median.

 Use Surface Templates to create concrete caps on the islands and median.
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Model the Interior Areas of the Islands and Median

In this exercise, you will use the terrain tools to create the interior of the islands and the median. The interiors of the islands and median are 
composed of concrete. In order to model these areas you must first create a terrain model and then apply a surface template.

1. Create a terrain model of the area inside the north island.

a. In View 2, zoom to the north island.

b. Select Terrain > Create > Create From Elements

c. On the dialog box, set the following:

 Feature Definition: Proposed Triangles

 Name: North Island Cap

d. Following the heads up prompts (after each prompt, Left-click to accept 
values and move to next prompt):

 Locate Element To Add: In the 3D View, select the CURB_BACK_TOP 
feature.

 Locate Next Element to Add - Reset When Done: Right click or reset.

 Feature Type: Boundary

 Edge Method: None

 Data point to complete.
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The terrain is created and the island area is filled.

The next step is to assign a surface template the terrain model. The Apply Surface Template tool gives you the ability to add material depth 
and thickness to terrain models. 
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2. Apply a concrete surface template to the North Island terrain model.

a. Select Model Detailing > 3D Tools > Apply Surface Template

b. Following the heads up prompts (after each prompt, Left-click to accept values and move to next prompt):

 Feature Definition: Enable Linear Features

 Name: North Island Cap

 Locate a Terrain Model: Select North Island Cap terrain

 Apply External Clip Boundary: No

 Select Template - <ALT> Down To Browse Templates: Press <ALT> Down Arrow

 Select Surface Templates\Concrete Median

 Click OK to complete
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3. Create a terrain model of the area inside the South Island.

a. In View 2, zoom to the south island.

b. Select Terrain > Create > Create From Elements

c. On the dialog box, set the following:

 Feature Definition: Proposed Triangles

 Name: South Island Cap

d. Following the heads up prompts (after each prompt, Left-click to accept 
values and move to next prompt):

 Locate Element To Add: In the 3D View, select the CURB_BACK_TOP 
feature.

 Locate Next Element to Add - Reset When Done: Right click or reset.

 Feature Type: Boundary

 Edge Method: None

 Data point to complete.

The terrain is created and the island area is filled.
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4. Apply a concrete surface template to the South Island terrain model.

a. Select Model Detailing > 3D Tools > Apply Surface Template

b. Following the heads up prompts (after each prompt, Left-click to accept values and move to next prompt):

 Feature Definition: Enable Linear Features

 Name: South Island Cap

 Locate a Terrain Model: Select South Island Cap terrain

 Apply External Clip Boundary: No

 Select Template - <ALT> Down To Browse Templates: Press <ALT> Down Arrow

 Select Surface Templates\Concrete Median

 Click OK to complete
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5. Create a terrain model of the area inside the median.

a. In View 2, zoom to the median.

b. Select Terrain > Create > Create From Elements

c. On the dialog box, set the following:

 Feature Definition: Proposed Triangles

 Name: Median Island Cap

d. Following the heads up prompts (after each prompt, 
Left-click to accept values and move to next prompt):

 Locate Element To Add: In the 3D View, select the 
CURB_BACK_TOP feature.

 Locate Next Element to Add - Reset When Done: 
Right click or reset.

 Feature Type: Boundary

 Edge Method: None

 Data point to complete.

The terrain is created and the median area is filled.
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6. Apply a concrete surface template to the Median terrain model.

a. Select Model Detailing > 3D Tools > Apply Surface Template

b. Following the heads up prompts (after each prompt, Left-click to accept values and move to next prompt):

 Feature Definition: Enable Linear Features

 Name: Median Island Cap

 Locate a Terrain Model: Select Median Island Cap terrain

 Apply External Clip Boundary: No

 Select Template - <ALT> Down To Browse Templates: Press <ALT> Down Arrow

 Select Surface Templates\Concrete Median

 Click OK to complete
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Exercise 3: Model the Pavement Layers

Description
In this exercise, you will model the pavement layers.

Skills Taught
 Apply a Surface Template to the intersection pavement terrain model and create the pavement layers
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Apply a Surface Template to the Model Pavement Layers

In this exercise, you will model the pavement layers using a surface template.

1. Model the Pavement Layers

a. Select Model Detailing > 3D Tools > Apply Surface 
Template

b. Following the heads up prompts (after each prompt, Left-
click to accept values and move to next prompt):

 Feature Definition: Enable Linear Features

 Name: Pavement Layers

 Locate a Terrain Model: Select Intersection terrain

 Apply External Clip Boundary: No

 Select Template - <ALT> Down To Browse 
Templates: Press <ALT> Down Arrow

 Select Surface Templates\Concrete Pavement w/
Agg Base

 Click Ok to complete. The surface template has now been applied to the terrain model.
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2. Review the cross sections.

a. Open View 3.

b. Select Corridors > Review > Dynamic Sections > Open Cross Section View

c. Locate Corridor or Alignment: Select the Church Rd. centerline

 Left Offset: -100

 Right Offset: 100

 Station: 39+25

 Interval: 25

 Select or Open View: Left click in View 3

3. Navigate and review the cross sections. Note that the pavement layers appear on the sections as well as the island and median caps.
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Exercise 4: Model the Curb and Gutter, Sidewalks, and End Conditions

Description
In this exercise, you will model the curb and gutter, sidewalks, and external side slopes using a linear template.

Skills Taught
 Model the curb and gutter, sidewalks, and side slopes using a linear template.
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Model the Curb and Gutter, Sidewalk, and End Conditions

In this exercise, you will model the curb and gutter, sidewalks, and side slopes for the intersection using a linear template.

1. Apply the Curb/Gutter/Buffer - Sidewalk - Tie Slope Linear Template to the south edge of pavement.

a. Select the Apply Linear Template tool.

b. On the dialog box, toggle off all the check boxes to UNLOCK all the tool settings.

c. In View 1, Following the heads up prompts (after each prompt, Left-click to accept values and move to next prompt):

 Locate Element to Apply Template: Select the south edge of pavement element.

 Feature Definition: Linear Template > Final

 Name: RT Grading

 Template: Press <ALT> and the Down Arrow to open the template library. The Pick Template window will appear.

 Browse to the Linear Templates folder and select Curb/Gutter/Buffer - Sidewalk - Tie Slope and click OK

 Start Station: Press <ALT> to lock to start

 End Station: Press <ALT> to lock to end

 Select Side - Reflect Option: Move the cursor to the south away from the edge of pavement.

 Exterior Corner Sweep Angle: Do not change the setting. 

 Description: RT Grading
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The RT Grading Linear Template is now placed and the components are displayed in the 3D model (View 2).
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2. Apply the Curb/Gutter/Buffer - Sidewalk - Tie Slope Linear Template to the south curve taper edge of pavement geometry.

a. Select the Apply Linear Template tool.

b. On the dialog box, toggle off all the check boxes to UNLOCK all the tool settings.

c. In View 1, Following the heads up prompts (after each prompt, Left-click to accept values and move to next prompt):

 Locate Element to Apply Template: Select the south curve taper edge of pavement geometry.

 Feature Definition: Linear Template > Final

 Name: RT Return Grading

 Template: Press <ALT> and the Down Arrow to open the template library. The Pick Template window will appear.

 Browse to the Linear Templates folder and select Curb/Gutter/Buffer - Sidewalk - Tie Slope and click OK

 Start Station: Press <ALT> to lock to start

 End Station: Press <ALT> to lock to end

 Select Side - Reflect Option: Move the cursor to the southwest away from the curve taper geometry.

 Exterior Corner Sweep Angle: Do not change the setting. 

 Description: RT Return Grading
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3. Apply the Curb/Gutter/Buffer - Sidewalk - Tie Slope Linear Template to the north edge of pavement

a. Select the Apply Linear Template tool.

b. On the dialog box, toggle off all the check boxes to UNLOCK all the tool settings.

c. In View 1, Following the heads up prompts (after each prompt, Left-click to accept values and move to next prompt):

 Locate Element to Apply Template: Select the north edge of pavement element.

 Feature Definition: Linear Template > Final

 Name: LT Grading

 Template: Press <ALT> and the Down Arrow to open the template library. The Pick Template window will appear.

 Browse to the Linear Templates folder and select Curb/Gutter/Buffer - Sidewalk - Tie Slope and click OK

 Start Station: Press <ALT> to lock to start

 End Station: Press <ALT> to lock to end

 Select Side - Reflect Option: Move the cursor to the inside of the south island.

 Exterior Corner Sweep Angle: Do not change the setting. 

 Description: LT Grading
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4. Apply the Curb/Gutter/Buffer - Sidewalk - Tie Slope Linear Template to the north taper-curve-taper edge of pavement geometry.

a. Select the Apply Linear Template tool.

b. On the dialog box, toggle off all the check boxes to UNLOCK all the tool settings.

c. In View 1, Following the heads up prompts (after each prompt, Left-click to accept values and move to next prompt):

 Locate Element to Apply Template: Select the north taper-curve-taper edge of pavement geometry.

 Feature Definition: Linear Template > Final

 Name: LT Return Grading

 Template: Press <ALT> and the Down Arrow to open the template library. The Pick Template window will appear.

 Browse to the Linear Templates folder and select Curb/Gutter/Buffer - Sidewalk - Tie Slope and click OK

 Start Station: Press <ALT> to lock to start

 End Station: Press <ALT> to lock to end

 Select Side - Reflect Option: Move the cursor to the inside of the south island.

 Exterior Corner Sweep Angle: Do not change the setting. 

 Description: LT Return Grading
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5. In the 3D View change the Display Style to Transparent.

6. Review the 3D model and notice there is an overlap between the LT Grading linear template and the LT Return Grading linear template.

We will address this by using Corridor Clipping.

7. Clip the LT Return Grading Linear Template.

a. Left click in View 1 to make it active.

b. Select Corridors > Corridor Clipping > Add Clipping Reference

 Select Corridor To Be Clipped: Select the LT Return Grading linear template

 Locate First Clipping Reference: Select the LT Grading linear template

 Locate Next Clipping Reference-Reset to Complete: Right click or reset.

The components in the LT Return Grading linear template will be clipped out and the overlap will be removed.
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8. Review the 3D model and notice there is another overlap between the RT Return Grading linear template and the London Rd. corridor.

Again, we will address this by using Corridor Clipping.

9. Clip the RT Return Grading Linear Template.

a. Left click in View 1 to make it active.

b. Select Corridors > Corridor Clipping > Add Clipping Reference

 Select Corridor To Be Clipped: Select the RT Return Grading linear template.

 Locate First Clipping Reference: Select the London Rd. corridor.

 Locate Next Clipping Reference-Reset to Complete: Right click or reset.

The components in the RT Return Grading linear template will be clipped out and the overlap will be removed.
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10. Review the cross sections. If not already open, open the dynamic cross sections.

a. Open View 3.

b. Select Corridors > Review > Dynamic Cross Sections

c. Locate Corridor or Alignment: Select the Church Rd. centerline

 Left Offset: -100

 Right Offset: 100

 Station: 39+25

 Interval: 25

 Select or Open View: Left click in View 3

11. Navigate and review the cross sections.
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Exercise 5: Create Combined Finished Grade Terrain Model

Description
In this exercise, you will learn how to create a combined finished grade terrain model from the Church Rd. Corridor, Church Rd. Intersection, 
and the London Rd. Corridor.

Skills Taught
 Create Combined Finished Grade Terrain Model

 Display Finished Grade Terrain Model Contours

 Export Finished Grade Terrain Model to LandXML format
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Create Finish Grade Terrain Model Using Graphical Filters

1. Open Terrain_Proposed-FG.dgn

This is a 3D design file. The related corridors and intersection design files have already been attached as reference files.

2. Create the proposed finished grade terrain model.

a. Select Terrain > Create > From Graphical Filter. The Create Terrain Model Graphical Filter dialog will appear.

b. Select the browse button to the right of Graphical Filter Group, the Graphical Filters window will appear.

c. In the Graphical Filters window, Select Graphical Filter Group named: Proposed Finished Grade

d. Click the Preview button, the proposed finished grade 3D features will highlight.

e. Edge Method: None

f. Feature Definition: Proposed Drainage Contours

g. Name: Proposed FG

h. Append To Terrain: No

The terrain model will be created and displayed with the proposed contours.
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3. In the 3D View, Turn Off all reference files to better view the contours.

4. Review the 3D model contours.



Copyright © 2021 Bentley Systems, Incorporated 35DO NOT DISTRIBUTE - Printing for student use is permitted

Export Terrain Model to LandXML

Sometimes it’s necessary to export the proposed finished grade terrain model to other file formats. In this section, you will learn how to export 
the proposed finished grade terrain model to a LandXML file format.

1. Select Terrain > Miscellaneous > Export To File

2. Follow the heads-up prompts and left click to accept to move to the next prompt.

a. Select Terrain to Export: Select the proposed finished grade terrain model.

b. Select File Format: Set the format to LandXML (.xml)

c. Export Options: Project Name: Proposed FG

d. Export Options: Project Description: Proposed FG

e. Export Options: Export Options: Export Both

f. When the Export Terrain dialog appears, key-in Proposed FG.xml for the file name.

g. Click Save to save the file.
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Skills Assessment

The questions below will test your retention of the skills covered in this course.

1. Linear Templates can be used to model curbs, islands and medians.

a. True

b. False

2. To increase or decrease the accuracy of the linear templates when placed along linear elements, curves and profiles (choose all that 
apply):

a. Adjust the Stroking Defintion in the element properties.

b. Adjust the Stroking Defintion using Configuration Variables.

c. Increase or Decrease the Template Drop Interval.

d. Choose a more accurate Feature Definition.

3. Surface Templates allow you to apply a template to a terrain model so that you can model a materials thickness or depth.

a. True

b. False

4. Corridor Clipping allows you to remove areas of overlap between 3D components.

a. True

b. False

5. Which tool can be used to create a proposed finished grade terrain model?

a. Create Terrain From Corridors

b. Extract Graphical Features

c. Create Terrain Model From Graphical Filter
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Skills Assessment - Answers

The answers to the skills assessment questions are highlighted below. 

1. Linear Templates can be used to model curbs, islands and medians.

a. True

b. False

2. To increase or decrease the accuracy of the linear templates when placed along linear elements, curves and profiles (choose all that 
apply):

a. Adjust the Stroking Defintion in the element properties.

b. Adjust the Stroking Defintion using Configuration Variables.

c. Increase or Decrease the Template Drop Interval.

d. Choose a more accurate Feature Definition.

3. Surface Templates allow you to apply a template to a terrain model so that you can model a materials thickness or depth.

a. True

b. False

4. Corridor Clipping allows you to remove areas of overlap between 3D components.

a. True

b. False

5. Which tool can be used to create a proposed finished grade terrain model?

a. Create Terrain From Corridors

b. Extract Graphical Features

c. Create Terrain Model From Graphical Filter
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Summary

In this course you have now learned the tools and techniques that can be used to accurately model a complex intersection in 3D.

You have learned:

 How to use Linear Templates to create the curb, sidewalk and side slope grading along the edges of pavement and islands.

 How to use Surface Templates to apply material thickness to the pavement surface and median islands.

 How to Create a Finished Grade Terrain Model using Graphical Filters.

 Export Finished Grade Terrain Model to LandXML format.
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